summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTrent Nelson <trent@trent.me>2012-10-16 11:09:31 -0400
committerTrent Nelson <trent@trent.me>2012-10-16 11:09:31 -0400
commit65c60851b088a1d7e9b0d9638a18d43b7702c799 (patch)
tree8bfc8c9994aa7b2cdc654f8260b464c4e4b91e86 /configure.ac
parent68e9d7c1020ff67eaa269f3946b40ed2914e680b (diff)
parent56d4c03cb2971701db716f80a4d8bd5febce429a (diff)
downloadcpython-git-65c60851b088a1d7e9b0d9638a18d43b7702c799.tar.gz
Merge issue #15819: tweak logic in previous commit.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1762bd6688..bcf0387d51 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12,7 +12,7 @@ AC_INIT(python, PYTHON_VERSION, http://bugs.python.org/)
BUILDDIR="`pwd`"
AC_SUBST(BUILDDIR)
AC_SUBST(BASECPPFLAGS)
-if test "$srcdir" != "$BUILDDIR"; then
+if test "$srcdir" != "." -a "$srcdir" != "$BUILDDIR"; then
# If we're building out-of-tree, we need to make sure the following
# resources get picked up before their $srcdir counterparts.
# Objects/ -> typeslots.inc