summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVictor Stinner <vstinner@redhat.com>2019-04-26 01:40:00 +0200
committerGitHub <noreply@github.com>2019-04-26 01:40:00 +0200
commit5422e3cfb7ffc50b147b4662d6f596cd61533754 (patch)
tree6787f3f53164785273a6d4f59cd13d5a68ce1a27 /configure.ac
parent62dfd7d6fe11bfa0cd1d7376382c8e7b1275e38c (diff)
downloadcpython-git-5422e3cfb7ffc50b147b4662d6f596cd61533754.tar.gz
bpo-36722: Debug build loads libraries built in release mode (GH-12952)
In debug build, import now also looks for C extensions compiled in release mode and for C extensions compiled in the stable ABI.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 65d3f8e691..312758788e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4627,6 +4627,14 @@ AC_MSG_CHECKING(SOABI)
SOABI='cpython-'`echo $VERSION | tr -d .`${ABIFLAGS}${PLATFORM_TRIPLET:+-$PLATFORM_TRIPLET}
AC_MSG_RESULT($SOABI)
+if test "$Py_DEBUG" = 'true'; then
+ # Similar to SOABI but remove "d" flag from ABIFLAGS
+ AC_SUBST(ALT_SOABI)
+ ALT_SOABI='cpython-'`echo $VERSION | tr -d .``echo $ABIFLAGS | tr -d d`${PLATFORM_TRIPLET:+-$PLATFORM_TRIPLET}
+ AC_DEFINE_UNQUOTED(ALT_SOABI, "${ALT_SOABI}",
+ [Alternative SOABI used in debug build to load C extensions built in release mode])
+fi
+
AC_SUBST(EXT_SUFFIX)
case $ac_sys_system in
Linux*|GNU*|Darwin|VxWorks)