summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNed Deily <nad@acm.org>2014-11-20 02:11:03 -0800
committerNed Deily <nad@acm.org>2014-11-20 02:11:03 -0800
commit3f1d0b31218f54c94d42659a30580cda3a4e68ea (patch)
treeedb3aa425907d73a94d820667ec657fef6c8d1d9 /configure.ac
parenta86c091a736020d823f1676acec7319bc5493f2c (diff)
downloadcpython-git-3f1d0b31218f54c94d42659a30580cda3a4e68ea.tar.gz
Issue 22878: PEP 477 - "make install" and "make altinstall" integration
The backport of ensurepip to 2.7.9 allows pip to optionally be installed or upgraded using the bundled pip provided by the new ensurepip module. The option can be specified persistently using the configure option: ./configure --with-ensurepip[=upgrade|install|no] It can also be overridden on either the "install" or "altinstall" targets: make [alt]install ENSUREPIP=[upgrade|install|no] For Python 2, the default option is "no" (do not install pip).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 16da9f3999..94a215e0cf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4552,6 +4552,21 @@ for dir in $SRCDIRS; do
done
AC_MSG_RESULT(done)
+# ensurepip option
+AC_MSG_CHECKING(for ensurepip)
+AC_ARG_WITH(ensurepip,
+ [AS_HELP_STRING([--with(out)-ensurepip=@<:@=OPTION@:>@],
+ ["install" or "upgrade" using bundled pip, default is "no"])],
+ [],
+ [with_ensurepip=no])
+AS_CASE($with_ensurepip,
+ [yes|upgrade],[ENSUREPIP=upgrade],
+ [install],[ENSUREPIP=install],
+ [no],[ENSUREPIP=no],
+ [AC_MSG_ERROR([--with-ensurepip=upgrade|install|no])])
+AC_MSG_RESULT($ENSUREPIP)
+AC_SUBST(ENSUREPIP)
+
# generate output files
AC_CONFIG_FILES(Makefile.pre Modules/Setup.config Misc/python.pc)
AC_CONFIG_FILES([Modules/ld_so_aix], [chmod +x Modules/ld_so_aix])