summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2018-07-15 17:01:42 -0700
committerGitHub <noreply@github.com>2018-07-15 17:01:42 -0700
commit15c7b2abdfb93f8902dd72474818aee2bf97fa66 (patch)
treed3f11c73e2d4aaee2ed08a05e642547fb1bfff0a /configure.ac
parent16dfca4d829e45f36e71bf43f83226659ce49315 (diff)
downloadcpython-git-15c7b2abdfb93f8902dd72474818aee2bf97fa66.tar.gz
bpo-34121: Fix detection of C11 atomic support on clang. (GH-8288)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 99aca6650d..f33fd517cb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5347,7 +5347,6 @@ AC_LINK_IFELSE(
AC_LANG_SOURCE([[
#include <stdatomic.h>
atomic_int value = ATOMIC_VAR_INIT(1);
- _Atomic void *py_atomic_address = (void*) &value;
int main() {
int loaded_value = atomic_load(&value);
return 0;
@@ -5359,7 +5358,7 @@ AC_MSG_RESULT($have_stdatomic_h)
if test "$have_stdatomic_h" = yes; then
AC_DEFINE(HAVE_STD_ATOMIC, 1,
- [Has stdatomic.h, atomic_int and _Atomic void* types work])
+ [Has stdatomic.h with atomic_int])
fi
# Check for GCC >= 4.7 __atomic builtins