summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Klose <doko@ubuntu.com>2012-10-21 23:05:35 +0200
committerMatthias Klose <doko@ubuntu.com>2012-10-21 23:05:35 +0200
commitc4c4842d8625db87bfdd916a3751f90e8a0f9d88 (patch)
tree2d0e8864434375b85d234596b0e55744597a841a /configure.ac
parent5f8f0d67771257e762b6ab1b2eaa807f4608c7f5 (diff)
downloadcpython-git-c4c4842d8625db87bfdd916a3751f90e8a0f9d88.tar.gz
- Issue #16262: fix out-of-src-tree builds, if mercurial is not installed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index f2951a27fc..3e05304c4b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -867,12 +867,12 @@ else
HGBRANCH=""
fi
-AC_SUBST(DISABLE_ASDLGEN)
-DISABLE_ASDLGEN=""
-AC_CHECK_PROG(HAS_PYTHON, python, found, not-found)
-if test $HAS_HG != found -o $HAS_PYTHON != found
-then
- DISABLE_ASDLGEN="@echo hg: $HAS_HG, python: $HAS_PYTHON! cannot run \$(srcdir)/Parser/asdl_c.py #"
+AC_SUBST(ASDLGEN)
+AC_CHECK_PROGS(PYTHON, python$PACKAGE_VERSION python3 python, not-found)
+if $PYTHON = not-found; then
+ ASDLGEN="@echo python: $PYTHON! cannot run \$(srcdir)/Parser/asdl_c.py #"
+else
+ ASDLGEN="$PYTHON"
fi