summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTrent Nelson <trent@trent.me>2012-10-16 11:07:31 -0400
committerTrent Nelson <trent@trent.me>2012-10-16 11:07:31 -0400
commit56d4c03cb2971701db716f80a4d8bd5febce429a (patch)
tree5a902daa056e5a3d7b618e646ba530ed8e8cc821 /configure.ac
parentd6d5cf33ef7ad248a0baa2568f2a15a265a73734 (diff)
parent6603118125164b927d79eab89263a07a12406481 (diff)
downloadcpython-git-56d4c03cb2971701db716f80a4d8bd5febce429a.tar.gz
Merge issue #15819: tweak logic in previous commit.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0633a97aea..04413e905d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12,7 +12,7 @@ AC_INIT(python, PYTHON_VERSION, http://bugs.python.org/)
BUILDDIR="`pwd`"
AC_SUBST(BUILDDIR)
AC_SUBST(BASECPPFLAGS)
-if test "$srcdir" != "$BUILDDIR"; then
+if test "$srcdir" != "." -a "$srcdir" != "$BUILDDIR"; then
# If we're building out-of-tree, we need to make sure the following
# resources get picked up before their $srcdir counterparts.
# Objects/ -> typeslots.inc