summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMiss Islington (bot) <31488909+miss-islington@users.noreply.github.com>2017-11-01 06:11:12 -0700
committerSerhiy Storchaka <storchaka@gmail.com>2017-11-01 15:11:12 +0200
commit2be9a31213e93e26a71150efaef1a975f8b9afec (patch)
tree5485514a2d8c01bc5fd904c59434905c5a2eff30 /configure.ac
parent89b84b026b389f3c61cbbc5ee89afd8248721b0d (diff)
downloadcpython-git-2be9a31213e93e26a71150efaef1a975f8b9afec.tar.gz
bpo-31919: Fix building the curses module on OpenIndiana. (GH-4211) (#4215)
(cherry picked from commit 894ebd065e02debf20c0657d26020ecc42b7534f)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 33cb78df71..9a784e4636 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5071,6 +5071,17 @@ void *x=syncok
[AC_MSG_RESULT(no)]
)
+AC_MSG_CHECKING(for wchgat)
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <curses.h>]], [[
+#ifndef wchgat
+void *x=wchgat
+#endif
+]])],
+ [AC_DEFINE(HAVE_CURSES_WCHGAT, 1, Define if you have the 'wchgat' function.)
+ AC_MSG_RESULT(yes)],
+ [AC_MSG_RESULT(no)]
+)
+
AC_MSG_CHECKING(for filter)
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <curses.h>]], [[
#ifndef filter