summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..489985d
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,16 @@
+# This Makefile.PL creates a pass-through Makefile that simply calls
+# the equivalent Module::Build methods for each make target. See the
+# documentation for Module::Build::Compat for more information.
+
+use 5.006001;
+
+
+use lib qw(lib);
+
+# bootstrap configure_requires prereqs
+BEGIN { do 'inc/bootstrap.pl' or die defined($@) ? $@ : $! }
+
+use Module::Build::Compat;
+
+Module::Build::Compat->run_build_pl(args => \@ARGV);
+Module::Build::Compat->write_makefile(build_class => 'Module::Build');