summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorLorry Tar Creator <lorry-tar-importer@lorry>2012-02-16 20:42:36 +0000
committerLorry Tar Creator <lorry-tar-importer@lorry>2012-02-16 20:42:36 +0000
commitd550937a3b104e53897b8f51dd528724f721858a (patch)
tree170dfcf66aef688ef2ff094ca6d8140b63537953 /Makefile.PL
downloadLWP-MediaTypes-tarball-d550937a3b104e53897b8f51dd528724f721858a.tar.gz
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL45
1 files changed, 45 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..84a9995
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,45 @@
+#!perl -w
+
+require 5.006002;
+use strict;
+use ExtUtils::MakeMaker;
+
+WriteMakefile(
+ NAME => 'LWP::MediaTypes',
+ VERSION_FROM => 'lib/LWP/MediaTypes.pm',
+ ABSTRACT_FROM => 'lib/LWP/MediaTypes.pm',
+ AUTHOR => 'Gisle Aas <gisle@activestate.com>',
+ LICENSE => "perl",
+ MIN_PERL_VERSION => 5.006002,
+ PREREQ_PM => {
+ },
+ META_MERGE => {
+ resources => {
+ repository => 'http://github.com/gisle/lwp-mediatypes',
+ MailingList => 'mailto:libwww@perl.org',
+ }
+ },
+);
+
+
+BEGIN {
+ # compatibility with older versions of MakeMaker
+ my $developer = -f ".gitignore";
+ my %mm_req = (
+ LICENCE => 6.31,
+ META_MERGE => 6.45,
+ META_ADD => 6.45,
+ MIN_PERL_VERSION => 6.48,
+ );
+ undef(*WriteMakefile);
+ *WriteMakefile = sub {
+ my %arg = @_;
+ for (keys %mm_req) {
+ unless (eval { ExtUtils::MakeMaker->VERSION($mm_req{$_}) }) {
+ warn "$_ $@" if $developer;
+ delete $arg{$_};
+ }
+ }
+ ExtUtils::MakeMaker::WriteMakefile(%arg);
+ };
+}