summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL19
1 files changed, 19 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..cd6fe85
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,19 @@
+# This -*-perl-*- program writes the Makefile for installing this distribution.
+#
+# See "perldoc perlmodinstall" or "perldoc ExtUtils::MakeMaker" for
+# info on how to control how the installation goes.
+
+require 5.004;
+use strict;
+use ExtUtils::MakeMaker;
+
+WriteMakefile(
+ NAME => 'HTML::Tagset',
+ AUTHOR => 'Andy Lester <andy@petdance.com>',
+ VERSION_FROM => 'Tagset.pm', # finds $VERSION
+ ABSTRACT_FROM => 'Tagset.pm', # retrieve abstract from module
+ PMLIBDIRS => [qw(lib/)],
+ dist => { COMPRESS => 'gzip -9f', SUFFIX => 'gz', },
+ clean => { FILES => 'HTML-Tagset-*' },
+
+);