summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL80
1 files changed, 80 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..be20d7e
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,80 @@
+
+# This file was automatically generated by Dist::Zilla::Plugin::MakeMaker v5.011.
+use strict;
+use warnings;
+
+use 5.006;
+
+use ExtUtils::MakeMaker 6.30;
+
+
+
+my %WriteMakefileArgs = (
+ "ABSTRACT" => "Various portability utilities for module builders",
+ "AUTHOR" => "Ken Williams <kwilliams\@cpan.org>, Leon Timmermans <leont\@cpan.org>",
+ "BUILD_REQUIRES" => {},
+ "CONFIGURE_REQUIRES" => {
+ "ExtUtils::MakeMaker" => "6.30"
+ },
+ "DISTNAME" => "ExtUtils-Helpers",
+ "EXE_FILES" => [],
+ "LICENSE" => "perl",
+ "NAME" => "ExtUtils::Helpers",
+ "PREREQ_PM" => {
+ "Carp" => 0,
+ "Exporter" => "5.57",
+ "File::Basename" => 0,
+ "File::Copy" => 0,
+ "File::Spec::Functions" => 0,
+ "Module::Load" => 0,
+ "Text::ParseWords" => "3.24",
+ "strict" => 0,
+ "warnings" => 0
+ },
+ "TEST_REQUIRES" => {
+ "Cwd" => 0,
+ "File::Spec" => 0,
+ "IO::Handle" => 0,
+ "IPC::Open3" => 0,
+ "Test::More" => 0,
+ "lib" => 0
+ },
+ "VERSION" => "0.022",
+ "test" => {
+ "TESTS" => "t/*.t"
+ }
+);
+
+
+my %FallbackPrereqs = (
+ "Carp" => 0,
+ "Cwd" => 0,
+ "Exporter" => "5.57",
+ "File::Basename" => 0,
+ "File::Copy" => 0,
+ "File::Spec" => 0,
+ "File::Spec::Functions" => 0,
+ "IO::Handle" => 0,
+ "IPC::Open3" => 0,
+ "Module::Load" => 0,
+ "Test::More" => 0,
+ "Text::ParseWords" => "3.24",
+ "lib" => 0,
+ "strict" => 0,
+ "warnings" => 0
+);
+
+
+unless ( eval { ExtUtils::MakeMaker->VERSION(6.63_03) } ) {
+ delete $WriteMakefileArgs{TEST_REQUIRES};
+ delete $WriteMakefileArgs{BUILD_REQUIRES};
+ $WriteMakefileArgs{PREREQ_PM} = \%FallbackPrereqs;
+}
+
+delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
+ unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
+
+WriteMakefile(%WriteMakefileArgs);
+
+
+