summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorLorry Tar Creator <lorry-tar-importer@lorry>2014-06-25 15:37:31 +0000
committerLorry Tar Creator <lorry-tar-importer@lorry>2014-06-25 15:37:31 +0000
commitc8d851569c1b88d5431700809fe520cbca5023a8 (patch)
tree77099101cbc57151600ebad72697735043a3177a /Makefile.PL
downloadExtUtils-Config-tarball-master.tar.gz
ExtUtils-Config-0.008HEADExtUtils-Config-0.008master
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL63
1 files changed, 63 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..7a75db4
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,63 @@
+
+# This file was automatically generated by Dist::Zilla::Plugin::MakeMaker v5.019.
+use strict;
+use warnings;
+
+use 5.006;
+
+use ExtUtils::MakeMaker 6.30;
+
+
+
+my %WriteMakefileArgs = (
+ "ABSTRACT" => "A wrapper for perl's configuration",
+ "AUTHOR" => "Ken Williams <kwilliams\@cpan.org>, Leon Timmermans <leont\@cpan.org>",
+ "CONFIGURE_REQUIRES" => {
+ "ExtUtils::MakeMaker" => "6.30"
+ },
+ "DISTNAME" => "ExtUtils-Config",
+ "EXE_FILES" => [],
+ "LICENSE" => "perl",
+ "NAME" => "ExtUtils::Config",
+ "PREREQ_PM" => {
+ "Data::Dumper" => 0,
+ "strict" => 0,
+ "warnings" => 0
+ },
+ "TEST_REQUIRES" => {
+ "File::Spec" => 0,
+ "IO::Handle" => 0,
+ "IPC::Open3" => 0,
+ "Test::More" => "0.88"
+ },
+ "VERSION" => "0.008",
+ "test" => {
+ "TESTS" => "t/*.t"
+ }
+);
+
+
+my %FallbackPrereqs = (
+ "Data::Dumper" => 0,
+ "File::Spec" => 0,
+ "IO::Handle" => 0,
+ "IPC::Open3" => 0,
+ "Test::More" => "0.88",
+ "strict" => 0,
+ "warnings" => 0
+);
+
+
+unless ( eval { ExtUtils::MakeMaker->VERSION(6.63_03) } ) {
+ delete $WriteMakefileArgs{TEST_REQUIRES};
+ delete $WriteMakefileArgs{BUILD_REQUIRES};
+ $WriteMakefileArgs{PREREQ_PM} = \%FallbackPrereqs;
+}
+
+delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
+ unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
+
+WriteMakefile(%WriteMakefileArgs);
+
+
+