summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJim Meyering <meyering@fb.com>2020-02-06 09:00:26 -0800
committerJim Meyering <meyering@fb.com>2020-02-08 17:52:48 -0800
commitd7da53c47e3340af6a2e3e00918e94d6dc245903 (patch)
tree2faca98c4c53e6c0aff65be7c10a7ddfac945e8c /configure.ac
parentfa6d154b7b5afdfc81af25cffae7fbe1b99e8c2a (diff)
downloadcoreutils-d7da53c47e3340af6a2e3e00918e94d6dc245903.tar.gz
build: suppress new FP warning from gcc-10.0.1
* configure.ac (GNULIB_WARN_CFLAGS): Add -Wno-return-local-addr to avoid FP warning about careadlinkat.c. Discussed starting in https://lists.gnu.org/r/coreutils/2020-02/msg00006.html
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4eab50f1d..5fdb7e589 100644
--- a/configure.ac
+++ b/configure.ac
@@ -202,6 +202,10 @@ if test "$gl_gcc_warnings" = yes; then
# FIXME: it may be easy to remove this, since it affects only one file:
# the snprintf call at ftoastr.c:132.
nw="$nw -Wdouble-promotion"
+
+ # FIXME: remove this line when gcc improves
+ gl_WARN_ADD([-Wno-return-local-addr]) # FP in careadlinkat.c w/gcc 10.0.1 20200205
+
gl_MANYWARN_COMPLEMENT([GNULIB_WARN_CFLAGS], [$WARN_CFLAGS], [$nw])
AC_SUBST([GNULIB_WARN_CFLAGS])