summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2019-10-22 11:34:56 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2019-10-22 15:04:42 -0700
commit6716a79773adbd6b7639a78b0f5d444d974e9244 (patch)
tree24f45bb7c437a10b6cd8e06711f0fe4ec2e24cf5 /configure.ac
parentc1e19656c8aa7a1e81416e024af0cdfe652df7b2 (diff)
downloadcoreutils-6716a79773adbd6b7639a78b0f5d444d974e9244.tar.gz
build: re-enable type-limits checking
* configure.ac: When --enable-gcc-warnings is used, omit -Wno-type-limits. The need for -Wno-type-limits has passed, now that intprops.h uses builtin primitives for GCC 5 and later, given that recent GCCs issue type-limits warnings only for non-constant expressions. --enable-gcc-warnings is not intended for use with old compilers, so we can drop -Wno-type-limits now.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 0 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index d90c710e3..292ae0bf2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -134,7 +134,6 @@ if test "$gl_gcc_warnings" = yes; then
nw="$nw -Wswitch-enum" # Too many warnings for now
nw="$nw -Wswitch-default" # Too many warnings for now
nw="$nw -Wstack-protector" # not worth working around
- nw="$nw -Wtype-limits" # False alarms for portable code
nw="$nw -Wformat-overflow=2" # False alarms due to GCC bug 80776
nw="$nw -Wformat-truncation=2" # False alarm in ls.c, probably related
# things I might fix soon:
@@ -155,7 +154,6 @@ if test "$gl_gcc_warnings" = yes; then
gl_WARN_ADD([$w])
done
gl_WARN_ADD([-Wno-sign-compare]) # Too many warnings for now
- gl_WARN_ADD([-Wno-type-limits]) # False alarms for portable code
gl_WARN_ADD([-Wno-unused-parameter]) # Too many warnings for now
gl_WARN_ADD([-Wno-format-nonliteral])