summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPádraig Brady <P@draigBrady.com>2022-02-14 21:36:29 +0000
committerPádraig Brady <P@draigBrady.com>2022-02-15 17:07:22 +0000
commit63228501e68875cc072bf479d491ec39ffa01ba3 (patch)
tree17f46782cbdb89a1f1c8fdaa0c4e2d8846c747b9 /configure.ac
parent041dfff5db1f09c92435e46b65931b04364c37f6 (diff)
downloadcoreutils-63228501e68875cc072bf479d491ec39ffa01ba3.tar.gz
doc: use bold style for man page references
It's more common to use bold style than not, for references to other man pages. Ideally each man page renderer would highlight references, but currently some rely on styles in the page itself. * man/help2man: Implement a --bold-refs option that will mark up references like "name(1)" with bold style around the "name" component. * man/local.mk: Pass --bold-refs to our help2man unless disabled. * configure.ac: Add a --disable-bold-man-page-references option. Addresses https://bugs.gnu.org/53977
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 453baccff..7e4afc96f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -114,6 +114,20 @@ if test "$gl_single_binary" = 'symlinks'; then
fi
AM_CONDITIONAL([SINGLE_BINARY], [test "$gl_single_binary" != no])
+AC_ARG_ENABLE([bold-man-page-references],
+ [AS_HELP_STRING([--disable-bold-man-page-references],
+ [When generating man pages, do not apply bold style around any
+ references like name(1) etc.])],
+ [gl_bold_manpages=yes ;
+ case $enableval in
+ no|yes) gl_bold_manpages=$enableval ;;
+ *) AC_MSG_ERROR([bad value $enableval for bold-man-page-references.
+ Options are: yes, no.]) ;;
+ esac],
+ [gl_bold_manpages=yes]
+)
+AM_CONDITIONAL([BOLD_MAN_REFS], [test "$gl_bold_manpages" != no])
+
AC_ARG_ENABLE([gcc-warnings],
[AS_HELP_STRING([--enable-gcc-warnings@<:@=TYPE@:>@],
[control generation of GCC warnings. The TYPE 'no' disables