summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJoel E. Denny <jdenny@clemson.edu>2009-07-29 11:05:54 +0200
committerJim Meyering <meyering@redhat.com>2009-07-29 11:05:54 +0200
commit1bc5395e925ab555004960a33c2b772e0bd011ae (patch)
treebc575c6ae8708933adfc2e7fa778c354158d80a6 /Makefile.am
parentc91c85647c4dc98ea43b2b368f9be2ecf1855eba (diff)
downloadcoreutils-1bc5395e925ab555004960a33c2b772e0bd011ae.tar.gz
maint: improve update-copyright rule
* Makefile.am (update-copyright): Relax the selection rule to match any file containing the word "Copyright". Correct the exclusion rule so that it also excludes ChangeLog and COPYING files that are not in the top level directory.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 87e45451e..a243b7f24 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -148,7 +148,7 @@ check-ls-dircolors:
.PHONY: update-copyright
update-copyright:
if test -d .git; then \
- git grep -l -E '2[0-9]{3} +Free' \
- | grep -v -E '^(COPYING|ChangeLog)' \
+ git grep -l -w Copyright \
+ | grep -v -E '(^|/)(COPYING|ChangeLog)' \
| xargs $(srcdir)/build-aux/$@; \
fi