summaryrefslogtreecommitdiff
path: root/zephyr/test/qcom_power/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'zephyr/test/qcom_power/CMakeLists.txt')
-rw-r--r--zephyr/test/qcom_power/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/zephyr/test/qcom_power/CMakeLists.txt b/zephyr/test/qcom_power/CMakeLists.txt
new file mode 100644
index 0000000000..4a211dcc85
--- /dev/null
+++ b/zephyr/test/qcom_power/CMakeLists.txt
@@ -0,0 +1,13 @@
+# Copyright 2021 The ChromiumOS Authors
+# Use of this source code is governed by a BSD-style license that can be
+# found in the LICENSE file.
+
+cmake_minimum_required(VERSION 3.13.1)
+find_package(Zephyr REQUIRED HINTS "${ZEPHYR_BASE}")
+project(qcom_power)
+
+# Include the local test directory for shimmed_test_tasks.h
+zephyr_include_directories("${CMAKE_CURRENT_SOURCE_DIR}")
+
+FILE(GLOB_RECURSE test_sources src/*.c)
+target_sources(app PRIVATE ${test_sources})