summaryrefslogtreecommitdiff
path: root/zephyr/test/drivers/usb_malfunction_sink/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'zephyr/test/drivers/usb_malfunction_sink/CMakeLists.txt')
-rw-r--r--zephyr/test/drivers/usb_malfunction_sink/CMakeLists.txt15
1 files changed, 1 insertions, 14 deletions
diff --git a/zephyr/test/drivers/usb_malfunction_sink/CMakeLists.txt b/zephyr/test/drivers/usb_malfunction_sink/CMakeLists.txt
index 770f01b6d9..719366cb86 100644
--- a/zephyr/test/drivers/usb_malfunction_sink/CMakeLists.txt
+++ b/zephyr/test/drivers/usb_malfunction_sink/CMakeLists.txt
@@ -2,18 +2,5 @@
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
-# Create library name based on current directory
-zephyr_library_get_current_dir_lib_name(${ZEPHYR_BASE} lib_name)
-
-# Create interface library
-zephyr_interface_library_named(${lib_name})
-
-# Add include paths
-zephyr_include_directories("${CMAKE_CURRENT_SOURCE_DIR}")
-zephyr_include_directories("${CMAKE_CURRENT_SOURCE_DIR}/include")
-
# Add source files
-zephyr_library_sources("${CMAKE_CURRENT_SOURCE_DIR}/src/usb_malfunction_sink.c")
-
-# Link in the library
-zephyr_library_link_libraries(${lib_name})
+target_sources(app PRIVATE src/usb_malfunction_sink.c)