summaryrefslogtreecommitdiff
path: root/zephyr/test/drivers/isl923x/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'zephyr/test/drivers/isl923x/CMakeLists.txt')
-rw-r--r--zephyr/test/drivers/isl923x/CMakeLists.txt21
1 files changed, 4 insertions, 17 deletions
diff --git a/zephyr/test/drivers/isl923x/CMakeLists.txt b/zephyr/test/drivers/isl923x/CMakeLists.txt
index 36a97589c1..809d9f0862 100644
--- a/zephyr/test/drivers/isl923x/CMakeLists.txt
+++ b/zephyr/test/drivers/isl923x/CMakeLists.txt
@@ -2,21 +2,8 @@
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
-# Create library name based on current directory
-zephyr_library_get_current_dir_lib_name(${ZEPHYR_BASE} lib_name)
-
-# Create interface library
-zephyr_interface_library_named(${lib_name})
-
-# Add include paths
-zephyr_include_directories("${CMAKE_CURRENT_SOURCE_DIR}")
-zephyr_include_directories("${CMAKE_CURRENT_SOURCE_DIR}/include")
-
# Add source files
-zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_CONSOLE_CMD_CHARGER_ADC_AMON_BMON
- "${CMAKE_CURRENT_SOURCE_DIR}/src/console_cmd_amon_bmon.c")
-zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_CHARGE_RAMP_HW
- "${CMAKE_CURRENT_SOURCE_DIR}/src/charge_ramp_hw.c")
-
-# Link in the library
-zephyr_library_link_libraries(${lib_name})
+target_sources_ifdef(CONFIG_PLATFORM_EC_CONSOLE_CMD_CHARGER_ADC_AMON_BMON
+ app PRIVATE src/console_cmd_amon_bmon.c)
+target_sources_ifdef(CONFIG_PLATFORM_EC_CHARGE_RAMP_HW
+ app PRIVATE src/charge_ramp_hw.c)