summaryrefslogtreecommitdiff
path: root/zephyr/projects/volteer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'zephyr/projects/volteer/CMakeLists.txt')
-rw-r--r--zephyr/projects/volteer/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/zephyr/projects/volteer/CMakeLists.txt b/zephyr/projects/volteer/CMakeLists.txt
index 60d2a73e9a..61d7bbb7f4 100644
--- a/zephyr/projects/volteer/CMakeLists.txt
+++ b/zephyr/projects/volteer/CMakeLists.txt
@@ -32,10 +32,13 @@ zephyr_include_directories(
# Include selected EC source for the baseboard
target_sources(app PRIVATE "${PLATFORM_EC_BASEBOARD}/battery_presence.c")
+target_sources(app PRIVATE "${PLATFORM_EC_BASEBOARD}/charger.c")
target_sources(app PRIVATE "${PLATFORM_EC_BASEBOARD}/usb_pd_policy.c")
+# Include selected EC source for the board
+target_sources(app PRIVATE "${PLATFORM_EC_BOARD}/usbc_config.c")
+
# Local sources to make things build. These are being removed as we are able
# to build the EC source instead.
target_sources(app PRIVATE "src/battery.c")
target_sources(app PRIVATE "src/pwrok_signals.c")
-target_sources(app PRIVATE "src/usbc_config.c")