summaryrefslogtreecommitdiff
path: root/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'zephyr/CMakeLists.txt')
-rw-r--r--zephyr/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/zephyr/CMakeLists.txt b/zephyr/CMakeLists.txt
index dab7882231..79abbf07ff 100644
--- a/zephyr/CMakeLists.txt
+++ b/zephyr/CMakeLists.txt
@@ -61,6 +61,12 @@ if(DEFINED CONFIG_PLATFORM_EC)
set_property(TARGET app PROPERTY INTERPROCEDURAL_OPTIMIZATION True)
endif()
endif()
+
+ set_compiler_property(APPEND PROPERTY warning_base
+ # TODO(b/210501420): Make EC code compatible with
+ # -W-address-of-packed-member
+ -Wno-address-of-packed-member
+ )
endif()
# Switch from the "zephyr" library to the "app" library for all Chromium OS