summaryrefslogtreecommitdiff
path: root/zephyr/zmake/setup.py
diff options
context:
space:
mode:
authorJack Rosenthal <jrosenth@chromium.org>2021-01-08 12:30:48 -0700
committerCommit Bot <commit-bot@chromium.org>2021-01-09 03:28:08 +0000
commit2fa27104aa0e97f3c750aa3b04acfc76db5e7123 (patch)
tree7271f546938af224721a621ebeee2a1369048e0e /zephyr/zmake/setup.py
parent407a3cfc7c7423b3f03289b094bc1dfd2082a3c4 (diff)
downloadchrome-ec-2fa27104aa0e97f3c750aa3b04acfc76db5e7123.tar.gz
zephyr: copy zmake to platform/ec
This copies zmake into platform/ec/zephyr/zmake, as explained in go/zephyr-fewer-repos. Follow-on CLs will be submitted to: - Update the chromeos-base/zephyr-build-tools ebuild to reference this directory instead of the one in zephyr-chrome. - Remove the copy of zmake in zephyr-chrome. Those interested in the git history of this code prior to it being moved to platform/ec can find it here: https://chromium.googlesource.com/chromiumos/platform/zephyr-chrome/+log/bacea2e3e62c41000e5bdb4ed6433f24386d14bf/util BUG=b:177003034 BRANCH=none TEST=emerge with new path (requires follow-on CL) Signed-off-by: Jack Rosenthal <jrosenth@chromium.org> Change-Id: Ia957b3e35ce3b732968ebf8df603ef13298cc6b3 Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/2618501 Reviewed-by: Yuval Peress <peress@chromium.org>
Diffstat (limited to 'zephyr/zmake/setup.py')
-rw-r--r--zephyr/zmake/setup.py48
1 files changed, 48 insertions, 0 deletions
diff --git a/zephyr/zmake/setup.py b/zephyr/zmake/setup.py
new file mode 100644
index 0000000000..681a5b8d6a
--- /dev/null
+++ b/zephyr/zmake/setup.py
@@ -0,0 +1,48 @@
+# Copyright 2020 The Chromium OS Authors. All rights reserved.
+# Use of this source code is governed by a BSD-style license that can be
+# found in the LICENSE file.
+
+import setuptools
+
+
+setuptools.setup(
+ name='zephyr-chrome-utils',
+ version='0.1',
+
+ description='CrOS Zephyr Utilities',
+ long_description='Utilities used for working on a Zephyr-based EC',
+
+ url='https://chromium.googlesource.com/chromiumos/platform/zephyr-chrome',
+
+ author='Chromium OS Authors',
+ author_email='chromiumos-dev@chromium.org',
+
+ license='BSD',
+
+ # What does your project relate to?
+ keywords='chromeos',
+
+ # You can just specify the packages manually here if your project is
+ # simple. Or you can use find_packages().
+ packages=['zmake'],
+
+ python_requires='>=3.6, <4',
+
+ # List run-time dependencies here. These will be installed by pip when
+ # your project is installed. For an analysis of "install_requires" vs pip's
+ # requirements files see:
+ # https://packaging.python.org/en/latest/requirements.html
+ install_requires=[
+ 'jsonschema>=3.2.0',
+ 'pyyaml>=3.13',
+ ],
+
+ # To provide executable scripts, use entry points in preference to the
+ # "scripts" keyword. Entry points provide cross-platform support and allow
+ # pip to create the appropriate form of executable for the target platform.
+ entry_points={
+ 'console_scripts': [
+ 'zmake=zmake.__main__:main',
+ ],
+ },
+)