summaryrefslogtreecommitdiff
path: root/zephyr/zmake/setup.py
diff options
context:
space:
mode:
authorJack Rosenthal <jrosenth@chromium.org>2021-07-02 11:41:24 -0600
committerCommit Bot <commit-bot@chromium.org>2021-07-12 19:15:42 +0000
commit6580c97e48e7abca694f8f5d3e955bdf12a6ec55 (patch)
treebcda10463444802c8004fb46b4cb86ef5bc3a017 /zephyr/zmake/setup.py
parent0a639566d7e7769b7f627614c3359128c0c42763 (diff)
downloadchrome-ec-6580c97e48e7abca694f8f5d3e955bdf12a6ec55.tar.gz
zephyr: zmake: run black on all files, enable check in run_tests.sh
Run black on all files. Enable check in run_tests.sh to enforce future formatting requirements. BUG=b:192389533 BRANCH=none TEST=run_tests.sh Signed-off-by: Jack Rosenthal <jrosenth@chromium.org> Change-Id: I5d93ef61d32d0dab4fe4bf3a77faf3f6693be627 Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/3002839 Commit-Queue: Yuval Peress <peress@chromium.org> Reviewed-by: Yuval Peress <peress@chromium.org>
Diffstat (limited to 'zephyr/zmake/setup.py')
-rw-r--r--zephyr/zmake/setup.py39
1 files changed, 15 insertions, 24 deletions
diff --git a/zephyr/zmake/setup.py b/zephyr/zmake/setup.py
index 0aed990e09..4328dc48d7 100644
--- a/zephyr/zmake/setup.py
+++ b/zephyr/zmake/setup.py
@@ -5,43 +5,34 @@
import setuptools
setuptools.setup(
- name='zephyr-chrome-utils',
- version='0.1',
-
- description='CrOS Zephyr Utilities',
- long_description='Utilities used for working on a Zephyr-based EC',
-
- url='https://chromium.googlesource.com/chromiumos/platform/ec',
-
- author='Chromium OS Authors',
- author_email='chromiumos-dev@chromium.org',
-
- license='BSD',
-
+ name="zephyr-chrome-utils",
+ version="0.1",
+ description="CrOS Zephyr Utilities",
+ long_description="Utilities used for working on a Zephyr-based EC",
+ url="https://chromium.googlesource.com/chromiumos/platform/ec",
+ author="Chromium OS Authors",
+ author_email="chromiumos-dev@chromium.org",
+ license="BSD",
# What does your project relate to?
- keywords='chromeos',
-
+ keywords="chromeos",
# You can just specify the packages manually here if your project is
# simple. Or you can use find_packages().
- packages=['zmake'],
-
- python_requires='>=3.6, <4',
-
+ packages=["zmake"],
+ python_requires=">=3.6, <4",
# List run-time dependencies here. These will be installed by pip when
# your project is installed. For an analysis of "install_requires" vs pip's
# requirements files see:
# https://packaging.python.org/en/latest/requirements.html
install_requires=[
- 'jsonschema>=3.2.0',
- 'pyyaml>=3.13',
+ "jsonschema>=3.2.0",
+ "pyyaml>=3.13",
],
-
# To provide executable scripts, use entry points in preference to the
# "scripts" keyword. Entry points provide cross-platform support and allow
# pip to create the appropriate form of executable for the target platform.
entry_points={
- 'console_scripts': [
- 'zmake=zmake.__main__:main',
+ "console_scripts": [
+ "zmake=zmake.__main__:main",
],
},
)