summaryrefslogtreecommitdiff
path: root/zephyr/test/system/CMakeLists.txt
diff options
context:
space:
mode:
authorYuval Peress <peress@chromium.org>2021-01-15 12:06:31 -0700
committerCommit Bot <commit-bot@chromium.org>2021-02-03 23:49:02 +0000
commit41f52b709177f7ddff01f5b7a568c663bc495897 (patch)
tree147857c0886e21b1a8d62c2eef0b8c24dd548ce5 /zephyr/test/system/CMakeLists.txt
parent236e03723b4eb389a7846257ac5b6fb9e2faab5c (diff)
downloadchrome-ec-41f52b709177f7ddff01f5b7a568c663bc495897.tar.gz
zephyr: flash/system: enable common/flash.c & common/system.c
Bring both flash.c and system.c into the build. zephyr/shim/src/system.c now includes only code that is needed to stub out the chip specific system.c implementation in platform/ec (which is now using the devicetree values). BRANCH=none BUG=b:176828988, b:174481378 TEST=zmake testall TEST=build volteer, flash, and test flashinfo. Cq-Depend: chromium:2631353 Change-Id: I5c542fca01dcc4af98401bcbbf402e579cd45e36 Signed-off-by: Yuval Peress <peress@chromium.org> Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/2649463 Reviewed-by: Jack Rosenthal <jrosenth@chromium.org> Commit-Queue: Jack Rosenthal <jrosenth@chromium.org>
Diffstat (limited to 'zephyr/test/system/CMakeLists.txt')
-rw-r--r--zephyr/test/system/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/zephyr/test/system/CMakeLists.txt b/zephyr/test/system/CMakeLists.txt
index 2afa9d6301..f91786841e 100644
--- a/zephyr/test/system/CMakeLists.txt
+++ b/zephyr/test/system/CMakeLists.txt
@@ -6,5 +6,5 @@ cmake_minimum_required(VERSION 3.13.1)
find_package(Zephyr REQUIRED HINTS $ENV{ZEPHYR_BASE})
project(system_test)
-FILE(GLOB app_sources *.c)
-target_sources(app PRIVATE ${app_sources})
+target_sources(app PRIVATE test_system.c
+ ${PLATFORM_EC}/zephyr/shim/src/system.c)