summaryrefslogtreecommitdiff
path: root/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Marheine <pmarheine@chromium.org>2022-09-02 11:41:04 +1000
committerChromeos LUCI <chromeos-scoped@luci-project-accounts.iam.gserviceaccount.com>2022-10-09 23:47:50 +0000
commitdcaf98ce10e915f1d2095ff9793ada42d6397b8e (patch)
tree306ae588216896b6a70684041362faf402601a6f /zephyr/CMakeLists.txt
parent3e3536a3fbe3a6054c3970255a849c99cd170584 (diff)
downloadchrome-ec-dcaf98ce10e915f1d2095ff9793ada42d6397b8e.tar.gz
zephyr/usbc: implement a default DFP-only SVDM identity
Recent PD specifications require that devices with multiple DFPs respond to Discover Identity commands, even if they don't support any modes as responder. This implements a default handler for those commands appropriate for such devices that reports DFP-only operation, enabled by config and default-on for devices that aren't DRDs nor need extra SVDM support (such as for USB4 or TBT). This is implemented only for Zephyr (no equivalent implementation for legacy EC-OS) because it is expected that new devices which might benefit from it will all be using Zephyr. BUG=b:242671457 TEST=nereid now responds to Discover Identity, new test passes BRANCH=none Signed-off-by: Peter Marheine <pmarheine@chromium.org> Change-Id: I2d11ced6928ae65ca00d20a1646509281080243b Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/3868882 Reviewed-by: Diana Z <dzigterman@chromium.org> Reviewed-by: Aaron Massey <aaronmassey@google.com> Reviewed-by: Keith Short <keithshort@chromium.org> Code-Coverage: Zoss <zoss-cl-coverage@prod.google.com>
Diffstat (limited to 'zephyr/CMakeLists.txt')
-rw-r--r--zephyr/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/zephyr/CMakeLists.txt b/zephyr/CMakeLists.txt
index 920151341c..290fe337f9 100644
--- a/zephyr/CMakeLists.txt
+++ b/zephyr/CMakeLists.txt
@@ -445,6 +445,8 @@ zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USB_PD_TBT_COMPAT_MODE
"${PLATFORM_EC}/common/usbc/tbt_alt_mode.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USB_PD_USB4
"${PLATFORM_EC}/common/usbc/usb_mode.c")
+zephyr_library_sources_ifdef(CONFIG_SVDM_RSP_DFP_ONLY
+ "${PLATFORM_EC}/common/usbc/svdm_rsp_dfp_only.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USBC_OCP
"${PLATFORM_EC}/common/usbc_ocp.c")