summaryrefslogtreecommitdiff
path: root/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
authorDerek Huang <derekhuang@google.com>2022-09-20 07:48:58 +0000
committerChromeos LUCI <chromeos-scoped@luci-project-accounts.iam.gserviceaccount.com>2022-09-21 02:45:23 +0000
commitab29d7e1550fc3f92b1847072a0dbd442cfa30dd (patch)
tree503fd5abd8dceadcd20722d6fe858b4099da316e /zephyr/CMakeLists.txt
parentcbf2ab787e86524eed964923e54c833b584a814f (diff)
downloadchrome-ec-ab29d7e1550fc3f92b1847072a0dbd442cfa30dd.tar.gz
ec: Shim PLATFORM_EC_CPS8100
Shim CONFIG_PLATFORM_EC_CPS8100 in zephyr to CONFIG_CPS8100 in legacy ec. BRANCH=None BUG=b:239783274 TEST=make -j40 buildall && util/run_tests.sh Change-Id: I15e2009b810102caaee54d59c48015a34a979f49 Signed-off-by: Derek Huang <derekhuang@google.com> Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/3905451 Reviewed-by: Daisuke Nojiri <dnojiri@chromium.org>
Diffstat (limited to 'zephyr/CMakeLists.txt')
-rw-r--r--zephyr/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/zephyr/CMakeLists.txt b/zephyr/CMakeLists.txt
index 83a94c3b41..7a71823bc8 100644
--- a/zephyr/CMakeLists.txt
+++ b/zephyr/CMakeLists.txt
@@ -253,6 +253,8 @@ zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_CHARGE_RAMP_HW
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_CHARGE_RAMP_SW
"${PLATFORM_EC}/common/charge_ramp.c"
"${PLATFORM_EC}/common/charge_ramp_sw.c")
+zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_CPS8100
+ "${PLATFORM_EC}/driver/wpc/cps8100.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_OCPC
"${PLATFORM_EC}/common/ocpc.c")