summaryrefslogtreecommitdiff
path: root/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
authorRajesh Kumar <rajesh3.kumar@intel.com>2022-07-13 12:17:14 -0700
committerChromeos LUCI <chromeos-scoped@luci-project-accounts.iam.gserviceaccount.com>2022-08-12 21:47:06 +0000
commit6d64c0adacbfb81fab4ca1d0f2eeb3c55a8fa43b (patch)
tree5630a0ae6ee5a028d858dc72dbb03f889cb51aff /zephyr/CMakeLists.txt
parent8bbb22cba3aac9cda691f23ed2116a694fcef5f1 (diff)
downloadchrome-ec-6d64c0adacbfb81fab4ca1d0f2eeb3c55a8fa43b.tar.gz
zephyr: ap_pwrseq: Add S0IX error recovery support
This CL supports s0ix error recovery to ensure the AP doesn't get itself stuck in a state where it's no longer in a sleep state (S0ix/S3), but from the Linux perspective is still suspended. BUG=none BRANCH=none TEST=zmake build nivviks Tested using 'powerd_dbus_suspend' on AP and observed timeout and hang detected through EC logs. Signed-off-by: Rajesh Kumar <rajesh3.kumar@intel.com> Change-Id: Iaf37b2afc7e1bdec251b9c21f6a3f131acab6a50 Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/3760670 Reviewed-by: Andrew McRae <amcrae@google.com>
Diffstat (limited to 'zephyr/CMakeLists.txt')
-rw-r--r--zephyr/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/zephyr/CMakeLists.txt b/zephyr/CMakeLists.txt
index 67fb77e977..526ea3e113 100644
--- a/zephyr/CMakeLists.txt
+++ b/zephyr/CMakeLists.txt
@@ -556,8 +556,6 @@ zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_MAX695X_SEVEN_SEGMENT_DISPLAY
"${PLATFORM_EC}/driver/led/max695x.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_LED_DRIVER_TLC59116F
"${PLATFORM_EC}/driver/led/tlc59116f.c")
-zephyr_library_sources_ifdef(CONFIG_AP_PWRSEQ_HOST_SLEEP
- "${PLATFORM_EC}/power/host_sleep.c")
# Switch to ec_shim library for all Zephyr sources
set(ZEPHYR_CURRENT_LIBRARY ec_shim)