summaryrefslogtreecommitdiff
path: root/zephyr/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Marheine <pmarheine@chromium.org>2022-07-08 11:40:51 +1000
committerChromeos LUCI <chromeos-scoped@luci-project-accounts.iam.gserviceaccount.com>2022-07-12 00:38:51 +0000
commit3e58b71d7ad9417907f8bf02842f4e931b27f4c8 (patch)
tree354dc0451162d5646c6f6f67eeac69feb8fccd45 /zephyr/CMakeLists.txt
parente0fad9b5ffcaf2bc1b80771198bc1f6972191234 (diff)
downloadchrome-ec-3e58b71d7ad9417907f8bf02842f4e931b27f4c8.tar.gz
ps8xxx: simplify Kconfig options for driver selection
Introduce a PLATFORM_EC_USB_PD_TCPM_PS8XXX option that enables the ps8xxx driver, and have the options for individual chips select it. This reduces the number of statements for each chip, and makes it clear that the multi-chip support option is only relevant if at least one chip is enabled. BUG=b:236761058,b:237593618 TEST=Verified ps8xxx.c is still built on Nereid, and selected/implied options remain enabled with the PS8815 driver. BRANCH=none Change-Id: I6a2215e7496613fc5daada154497c2ba2ac5c44b Signed-off-by: Peter Marheine <pmarheine@chromium.org> Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/ec/+/3752184 Reviewed-by: Keith Short <keithshort@chromium.org>
Diffstat (limited to 'zephyr/CMakeLists.txt')
-rw-r--r--zephyr/CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/zephyr/CMakeLists.txt b/zephyr/CMakeLists.txt
index b3eaefb2a3..60985762d4 100644
--- a/zephyr/CMakeLists.txt
+++ b/zephyr/CMakeLists.txt
@@ -481,11 +481,7 @@ zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USB_PD_TCPM_CCGXXF
"${PLATFORM_EC}/driver/tcpm/ccgxxf.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USB_PD_TCPM_NCT38XX
"${PLATFORM_EC}/driver/tcpm/nct38xx.c")
-zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USB_PD_TCPM_PS8751
- "${PLATFORM_EC}/driver/tcpm/ps8xxx.c")
-zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USB_PD_TCPM_PS8805
- "${PLATFORM_EC}/driver/tcpm/ps8xxx.c")
-zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USB_PD_TCPM_PS8815
+zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USB_PD_TCPM_PS8XXX
"${PLATFORM_EC}/driver/tcpm/ps8xxx.c")
zephyr_library_sources_ifdef(CONFIG_PLATFORM_EC_USB_PD_TCPM_RAA489000
"${PLATFORM_EC}/driver/tcpm/raa489000.c")