summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBob Moragues <moragues@google.com>2018-06-15 12:59:38 -0700
committerchrome-bot <chrome-bot@chromium.org>2018-06-17 15:23:25 -0700
commit966802817aeb59a32dc72d5330252881a06010ce (patch)
tree21a1814d3d697d1ea1f8e15b92b6ea9e2fc4821e /setup.py
parentee5d8b8a627381e906369f6c108dab7be2ac7518 (diff)
downloadchrome-ec-966802817aeb59a32dc72d5330252881a06010ce.tar.gz
util: add unpack_ftb to setup.py
unpack_ftb is used as a build tool to convert .ftb to .bin BUG=b:109719787 TEST=verify that unpack_ftb is present and executable Change-Id: I65c77cb13fd2866aabd2975979d943063cd615c6 Reviewed-on: https://chromium-review.googlesource.com/1103058 Commit-Ready: Bob Moragues <moragues@chromium.org> Tested-by: Bob Moragues <moragues@chromium.org> Reviewed-by: Wei-Han Chen <stimim@chromium.org> Reviewed-by: Nicolas Boichat <drinkcat@chromium.org>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 14 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 7cb689d41f..9ad66ac454 100644
--- a/setup.py
+++ b/setup.py
@@ -72,3 +72,17 @@ setup(
description="Tool to open the usb console on servo, cr50.",
)
+setup(
+ name="unpack_ftb",
+ version="1.0",
+ author="Wei-Han Chen",
+ author_email="stimim@chromium.org",
+ url="https://www.chromium.org/chromium-os/ec-development",
+ package_dir={"" : "util"},
+ py_modules=["unpack_ftb"],
+ entry_points = {
+ "build_scripts": ["unpack_ftb=unpack_ftb:main"],
+ },
+ description="Tool to convert .ftb files to .bin",
+)
+