summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGlenn Schmottlach <Glenn.Schmottlach@xs-embedded.com>2014-02-10 16:18:55 -0500
committerPatrik Flykt <patrik.flykt@linux.intel.com>2014-02-14 10:25:05 +0200
commit9abdf5f8e003216f68ea11ec8e5fdd6ea1b0263d (patch)
treece1a78ff1097ddad0d0d14a75530ce7d6a05540e /configure.ac
parent1e4e965286c1e4779dc57162510c59c891fe6e9b (diff)
downloadconnman-9abdf5f8e003216f68ea11ec8e5fdd6ea1b0263d.tar.gz
plugins: Refactor Gadget into separate plugin and file.
Move Linux Gadget, i.e. USB client, device support into a separate plug-in instead of being combined with the Ethernet plug-in. Change the prefix of several ethernet driver function names to be more consistent with the underlying driver (e.g. cable_ -> eth_network_, ethernet_ -> eth_dev_, eth_ -> eth_tech_).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 52b85b2e..8519eb8e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -286,6 +286,11 @@ AC_ARG_ENABLE(ethernet, AC_HELP_STRING([--disable-ethernet],
[enable_ethernet=${enableval}])
AM_CONDITIONAL(ETHERNET, test "${enable_ethernet}" != "no")
+AC_ARG_ENABLE(gadget, AC_HELP_STRING([--disable-gadget],
+ [disable USB Gadget support]),
+ [enable_gadget=${enableval}])
+AM_CONDITIONAL(GADGET, test "${enable_gadget}" != "no")
+
AC_ARG_ENABLE(wifi, AC_HELP_STRING([--disable-wifi],
[disable WiFi support]),
[enable_wifi=${enableval}])