summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJukka Rissanen <jukka.rissanen@linux.intel.com>2015-04-02 13:23:03 +0300
committerPatrik Flykt <patrik.flykt@linux.intel.com>2015-04-08 11:20:18 +0300
commit950b60c20cde08e04bd4311f0d4948b308b97152 (patch)
tree5189c1bf70d1de89204ccb59a751f3686a6b35cf /configure.ac
parent867ed453cbcbee00640e53b7835f616fca918b4d (diff)
downloadconnman-950b60c20cde08e04bd4311f0d4948b308b97152.tar.gz
build: Add option to set path of the pptp binary
User can set the path to client binary using --with-pptp option.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 85c01b90..5eb5a34b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -146,6 +146,9 @@ fi
AM_CONDITIONAL(L2TP, test "${enable_l2tp}" != "no")
AM_CONDITIONAL(L2TP_BUILTIN, test "${enable_l2tp}" = "builtin")
+AC_ARG_WITH(pptp, AC_HELP_STRING([--with-pptp=PROGRAM],
+ [specify location of pptp binary]), [path_pptp=${withval}])
+
AC_ARG_ENABLE(pptp,
AC_HELP_STRING([--enable-pptp], [enable pptp support]),
[enable_pptp=${enableval}], [enable_pptp="no"])