summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHenrik Persson <Henrik.Persson@verisure.com>2019-03-18 11:58:24 +0000
committerDaniel Wagner <wagi@monom.org>2019-03-18 20:11:54 +0100
commit516af0fd1586e1b78763b905d1136918ddd986f8 (patch)
tree6b75c367e66d5d722100d993ce9da05e6a553d0f /configure.ac
parentc1debcac758ef1f76a788225679003e2e67d9fdf (diff)
downloadconnman-516af0fd1586e1b78763b905d1136918ddd986f8.tar.gz
service: Sanitize input for hostname and domainname
If a DHCP ACK is received with non-UTF-8 data set as hostname or domain-name option connman will crash on a D-Bus assert. This patch sanitizes data in service.c and only allows ASCII characters (since they shouldn't be anything else) for __connman_service_set_hostname() and __connman_service_set_domainname(). Since the fix involves using g_str_is_ascii() we also need to bump Glib dependency to 2.40 (which was released in March 2014). See also - IETF RFC 1123 ⟨http://www.ietf.org/rfc/rfc1123.txt⟩ - IETF RFC 1178 ⟨http://www.ietf.org/rfc/rfc1178.txt⟩
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0bb2a6d9..a6e14b76 100644
--- a/configure.ac
+++ b/configure.ac
@@ -221,8 +221,8 @@ fi
AC_DEFINE_UNQUOTED([STATS_MAX_FILE_SIZE], (${stats_max_file_size}), [Maximal size of a statistics round robin file])
-PKG_CHECK_MODULES(GLIB, glib-2.0 >= 2.28, dummy=yes,
- AC_MSG_ERROR(GLib >= 2.28 is required))
+PKG_CHECK_MODULES(GLIB, glib-2.0 >= 2.40, dummy=yes,
+ AC_MSG_ERROR(GLib >= 2.40 is required))
AC_SUBST(GLIB_CFLAGS)
AC_SUBST(GLIB_LIBS)