summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Wagner <wagi@monom.org>2019-07-19 10:04:34 +0200
committerDaniel Wagner <wagi@monom.org>2019-11-07 08:53:01 +0100
commit4e1546be9537294af18be022de90f479b0799b02 (patch)
treecedcb4e310c96a4459614b19a458e8d436b4cb9f /configure.ac
parent966b251d390f1571f08617bcf5bc0d58cda24e09 (diff)
downloadconnman-4e1546be9537294af18be022de90f479b0799b02.tar.gz
build: Test for libmnl independent of nftables
Instead searching for libmnl and nftables in one test, split into two seperate tests. We need libmnl for WireGuard too.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 11 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ee49a22c..69e9f538 100644
--- a/configure.ac
+++ b/configure.ac
@@ -287,10 +287,19 @@ if (test "${firewall_type}" = "iptables"); then
fi
AM_CONDITIONAL(XTABLES, test "${found_iptables}" != "no")
+found_libmnl="no"
+if (test "${firewall_type}" = "nftables"); then
+ PKG_CHECK_MODULES(LIBMNL, [libmnl >= 1.0.0], [found_libmnl="yes"],
+ AC_MSG_ERROR([libmnl >= 1.0.0 not found]))
+ AC_SUBST(LIBMNL_CFLAGS)
+ AC_SUBST(LIBMNL_LIBS)
+fi
+AM_CONDITIONAL(LIBMNL, test "${found_libmnl}" != "no")
+
found_nftables="no"
if (test "${firewall_type}" = "nftables"); then
- PKG_CHECK_MODULES(NFTABLES, [libnftnl >= 1.0.4 libmnl >= 1.0.0], [found_nftables="yes"],
- AC_MSG_ERROR([libnftnl >= 1.0.4 or libmnl >= 1.0.0 not found]))
+ PKG_CHECK_MODULES(NFTABLES, [libnftnl >= 1.0.4], [found_nftables="yes"],
+ AC_MSG_ERROR([libnftnl >= 1.0.4]))
AC_SUBST(NFTABLES_CFLAGS)
AC_SUBST(NFTABLES_LIBS)
fi