summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJonas Bonn <jonas@southpole.se>2017-12-20 11:24:31 +0100
committerDaniel Wagner <wagi@monom.org>2018-01-04 08:23:27 +0100
commit4dc294bb9e9e23292988fdb98e1b66152bbf6f88 (patch)
treebcab8683212fbaaf74ab0d8c34e61f0c142b8f6b /configure.ac
parentbbb7b926cb84a5a59c32cc1bedf939b6957751b9 (diff)
downloadconnman-4dc294bb9e9e23292988fdb98e1b66152bbf6f88.tar.gz
build: Install DBus policy in /usr/share/dbus-1/system.d
The default location for DBus policy files should be /usr/share/dbus-1/system.d and the corresponding directory under /etc should be reserved for administrative changes to default/packaged settings. This removes a dependency of connman on a populated /etc.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4feccc08..3cdf4b29 100644
--- a/configure.ac
+++ b/configure.ac
@@ -230,9 +230,9 @@ AC_SUBST(DBUS_LIBS)
AC_ARG_WITH(dbusconfdir, AC_HELP_STRING([--with-dbusconfdir=PATH],
[path to D-Bus config directory]), [path_dbusconf=${withval}],
- [path_dbusconf="`$PKG_CONFIG --variable=sysconfdir dbus-1`"])
+ [path_dbusconf="`$PKG_CONFIG --variable=datadir dbus-1`"])
if (test -z "${path_dbusconf}"); then
- DBUS_CONFDIR="${sysconfdir}/dbus-1/system.d"
+ DBUS_CONFDIR="${datadir}/dbus-1/system.d"
else
DBUS_CONFDIR="${path_dbusconf}/dbus-1/system.d"
fi