summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Novakovic <chris@chrisn.me.uk>2018-03-04 17:59:53 +0000
committerDaniel Wagner <wagi@monom.org>2018-03-08 06:53:27 +0100
commit1946bbe055d19869ba4e28700a55b96fc052fbe5 (patch)
tree849d0e2b14c3ff296b0fc3e2edc449d01d447afa /configure.ac
parent3edfba04986e8e87a6eb641e45734afe982166f9 (diff)
downloadconnman-1946bbe055d19869ba4e28700a55b96fc052fbe5.tar.gz
build: Add --disable-stats option
Generation of interface statistics files can now be controlled at compile-time using the --{enable,disable}-stats configure options. Statistics files remain enabled by default. Based on an idea by Feng Wang <wangfe@nestlabs.com>.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3cdf4b29..c1f037dc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -380,6 +380,11 @@ AC_ARG_ENABLE(tools, AC_HELP_STRING([--disable-tools],
[enable_tools=${enableval}])
AM_CONDITIONAL(TOOLS, test "${enable_tools}" != "no")
+AC_ARG_ENABLE(stats, AC_HELP_STRING([--disable-stats],
+ [disable statistics round robin file generation]),
+ [enable_stats=${enableval}])
+AM_CONDITIONAL(STATS, test "${enable_stats}" != "no")
+
if (test "${enable_tools}" != "no"); then
AC_PATH_PROGS(IPTABLES_SAVE, [iptables-save], [],
$PATH:/sbin:/usr/sbin)