summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSanttu Lakkala <santtu.lakkala@jolla.com>2021-04-09 09:48:16 +0300
committerDaniel Wagner <wagi@monom.org>2021-04-18 13:02:32 +0200
commit17c13bb84972b0ac7bbf4332b09874ad6c59144f (patch)
tree5a4cea5688b3f0cd66a7c46925e95f61c6c4e949 /configure.ac
parent561f318003c14fff56720309b6c9dfdbceb8dd87 (diff)
downloadconnman-17c13bb84972b0ac7bbf4332b09874ad6c59144f.tar.gz
Rewrite openconnect plugin to use libopenconnect
Replace most of the fork/exec and output parsing with usage of libopenconnect for authentication. The actual connection establishment is still done by calling the openconnect binary using the token obtained via the use of the library. The library has a proprietary main loop and provides only a synchronous API, which is worked around by using a thread to run the authentication. Events from the library are delegated to the main thread via main loop.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 55057721..efde8cf6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -82,6 +82,8 @@ if (test "${enable_openconnect}" != "no"); then
OPENCONNECT="${path_openconnect}"
AC_SUBST(OPENCONNECT)
fi
+ PKG_CHECK_MODULES(LIBOPENCONNECT, openconnect >= 8, [],
+ AC_MSG_ERROR(openconnect >= 8 is required))
fi
AM_CONDITIONAL(OPENCONNECT, test "${enable_openconnect}" != "no")
AM_CONDITIONAL(OPENCONNECT_BUILTIN, test "${enable_openconnect}" = "builtin")