summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrik Flykt <patrik.flykt@linux.intel.com>2014-11-19 12:46:50 +0200
committerPatrik Flykt <patrik.flykt@linux.intel.com>2014-11-24 11:03:02 +0200
commitf0eebaed17487174ebca1fa8a37ff83c3e9d4941 (patch)
tree51e6ad958a8b6eb6e0ddc4cc0b682529efd7c099 /Makefile.am
parent07ca646b8cedbafe6b4b704222f2e3738924c1a3 (diff)
downloadconnman-f0eebaed17487174ebca1fa8a37ff83c3e9d4941.tar.gz
util: Use proper source for random numbers
Use /dev/urandom as the proper source for random numbers. Use libc as a fallback if /dev/urandom does not exist or becomes unreadable.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a5741701..09a0d6b9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -106,7 +106,7 @@ src_connmand_SOURCES = $(gdhcp_sources) $(gweb_sources) \
src/stats.c src/iptables.c src/dnsproxy.c src/6to4.c \
src/ippool.c src/bridge.c src/nat.c src/ipaddress.c \
src/inotify.c src/firewall.c src/ipv6pd.c src/peer.c \
- src/peer_service.c src/machine.c
+ src/peer_service.c src/machine.c src/util.c
src_connmand_LDADD = gdbus/libgdbus-internal.la $(builtin_libadd) \
@GLIB_LIBS@ @DBUS_LIBS@ @XTABLES_LIBS@ @GNUTLS_LIBS@ \