summaryrefslogtreecommitdiff
path: root/test/sanitizer_common/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/sanitizer_common/CMakeLists.txt')
-rw-r--r--test/sanitizer_common/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/test/sanitizer_common/CMakeLists.txt b/test/sanitizer_common/CMakeLists.txt
index 48fccf058..fcd651ebe 100644
--- a/test/sanitizer_common/CMakeLists.txt
+++ b/test/sanitizer_common/CMakeLists.txt
@@ -1,6 +1,11 @@
set(SANITIZER_COMMON_LIT_SOURCE_DIR ${CMAKE_CURRENT_SOURCE_DIR})
set(SANITIZER_COMMON_TEST_DEPS ${SANITIZER_COMMON_LIT_TEST_DEPS})
+
+if(CMAKE_HOST_UNIX)
+ list(APPEND SANITIZER_COMMON_TEST_DEPS SanitizerLintCheck)
+endif()
+
set(SANITIZER_COMMON_TESTSUITES)
# FIXME(dliew): We should switch to COMPILER_RT_SANITIZERS_TO_BUILD instead of