summaryrefslogtreecommitdiff
path: root/test/sanitizer_common/CMakeLists.txt
diff options
context:
space:
mode:
authorVitaly Buka <vitalybuka@google.com>2017-09-09 06:10:58 +0000
committerVitaly Buka <vitalybuka@google.com>2017-09-09 06:10:58 +0000
commit689b841c13f02c4f16a0f9d2bb5274e65ee7991a (patch)
tree1df3db32c817e22fb7a277bc555a44201a859f69 /test/sanitizer_common/CMakeLists.txt
parentc5cad77b92f072222f3680cd2ccf82543448e43b (diff)
downloadcompiler-rt-689b841c13f02c4f16a0f9d2bb5274e65ee7991a.tar.gz
[ubsan] Enable UBsan in sanitizer_common tests
Summary: Failing tests just marked as UNSUPPORTED or XFAIL. Some of them can be easily supported, but I'll do this in separate patches. Reviewers: eugenis, alekseyshl Subscribers: srhines, kubamracek, llvm-commits, mgorny Differential Revision: https://reviews.llvm.org/D37630 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@312860 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/sanitizer_common/CMakeLists.txt')
-rw-r--r--test/sanitizer_common/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/sanitizer_common/CMakeLists.txt b/test/sanitizer_common/CMakeLists.txt
index b716f89df..2a3d7a038 100644
--- a/test/sanitizer_common/CMakeLists.txt
+++ b/test/sanitizer_common/CMakeLists.txt
@@ -11,6 +11,7 @@ if(CMAKE_SYSTEM_NAME MATCHES "Linux" AND NOT ANDROID)
list(APPEND SUPPORTED_TOOLS tsan)
list(APPEND SUPPORTED_TOOLS msan)
list(APPEND SUPPORTED_TOOLS lsan)
+ list(APPEND SUPPORTED_TOOLS ubsan)
endif()
# Create a separate config for each tool we support.