summaryrefslogtreecommitdiff
path: root/lib/scudo/CMakeLists.txt
diff options
context:
space:
mode:
authorKostya Kortchinsky <kostyak@google.com>2018-06-15 16:45:19 +0000
committerKostya Kortchinsky <kostyak@google.com>2018-06-15 16:45:19 +0000
commita8f6940aafd86848e846cd811cafaaa3aa0fab70 (patch)
treef8cfdab75adaeb92bf9935366c8e3ccc00402d0a /lib/scudo/CMakeLists.txt
parente8b47a537f4c849e66e450dadddfbfe03d1f06fd (diff)
downloadcompiler-rt-a8f6940aafd86848e846cd811cafaaa3aa0fab70.tar.gz
[scudo] Add verbose failures in place of CHECK(0)
Summary: The current `FailureHandler` mechanism was fairly opaque with regard to the failure reason due to using `CHECK(0)`. Scudo is a bit different from the other Sanitizers as it prefers to avoid spurious processing in its failure path. So we just `dieWithMessage` using a somewhat explicit string. Adapted the tests for the new strings. While this takes care of the `OnBadRequest` & `OnOOM` failures, the next step is probably to migrate the other Scudo failures in the same failes (header corruption, invalid state and so on). Reviewers: alekseyshl Reviewed By: alekseyshl Subscribers: filcab, mgorny, delcypher, #sanitizers, llvm-commits Differential Revision: https://reviews.llvm.org/D48199 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@334843 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/scudo/CMakeLists.txt')
-rw-r--r--lib/scudo/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/scudo/CMakeLists.txt b/lib/scudo/CMakeLists.txt
index 3adfe6882..32472af5c 100644
--- a/lib/scudo/CMakeLists.txt
+++ b/lib/scudo/CMakeLists.txt
@@ -36,6 +36,7 @@ endif()
set(SCUDO_SOURCES
scudo_allocator.cpp
scudo_crc32.cpp
+ scudo_errors.cpp
scudo_flags.cpp
scudo_malloc.cpp
scudo_termination.cpp