summaryrefslogtreecommitdiff
path: root/lib/scudo/CMakeLists.txt
diff options
context:
space:
mode:
authorMitch Phillips <mitchphillips@outlook.com>2019-07-16 17:13:02 +0000
committerMitch Phillips <mitchphillips@outlook.com>2019-07-16 17:13:02 +0000
commit882efe25584f52e5e5bfa57da68f9235e4d84b3e (patch)
treeea8ea7549bf0b44663317d9e924b8d82068c6d49 /lib/scudo/CMakeLists.txt
parent5be36990b622b258669ec7c6420de2d64bba58b2 (diff)
downloadcompiler-rt-882efe25584f52e5e5bfa57da68f9235e4d84b3e.tar.gz
Removed -mno-omit-leaf-frame-pointer from flags.
Removes -mno-omit-leaf-frame-pointer from Scudo and GWP-ASan's CFlags. Attempt to fix the sanitizer buildbots. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@366228 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/scudo/CMakeLists.txt')
-rw-r--r--lib/scudo/CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/lib/scudo/CMakeLists.txt b/lib/scudo/CMakeLists.txt
index 9ee615c78..2a560b8fc 100644
--- a/lib/scudo/CMakeLists.txt
+++ b/lib/scudo/CMakeLists.txt
@@ -14,10 +14,6 @@ append_list_if(COMPILER_RT_HAS_LIBPTHREAD pthread SCUDO_MINIMAL_DYNAMIC_LIBS)
append_list_if(COMPILER_RT_HAS_LIBLOG log SCUDO_MINIMAL_DYNAMIC_LIBS)
append_list_if(COMPILER_RT_HAS_OMIT_FRAME_POINTER_FLAG -fno-omit-frame-pointer
SCUDO_CFLAGS)
-if ("${CMAKE_CXX_COMPILER_ID}" MATCHES "Clang")
- append_list_if(COMPILER_RT_HAS_OMIT_FRAME_POINTER_FLAG
- -mno-omit-leaf-frame-pointer SCUDO_CFLAGS)
-endif()
set(SCUDO_DYNAMIC_LINK_FLAGS ${SANITIZER_COMMON_LINK_FLAGS})
# Use gc-sections by default to avoid unused code being pulled in.