summaryrefslogtreecommitdiff
path: root/lib/fuzzer/CMakeLists.txt
diff options
context:
space:
mode:
authorKostya Serebryany <kcc@google.com>2019-04-19 01:39:14 +0000
committerKostya Serebryany <kcc@google.com>2019-04-19 01:39:14 +0000
commit6c875ed9e306b766079ebcf9adf2f4bd40c09411 (patch)
tree39247fa11af4536c4f97145727fe573aff5b36e8 /lib/fuzzer/CMakeLists.txt
parent3791c980f01c26facf86c3c954f41cbccabcae43 (diff)
downloadcompiler-rt-6c875ed9e306b766079ebcf9adf2f4bd40c09411.tar.gz
[libFuzzer] in fork mode, make sure the child stats are always collected. This should fix the flakiness in fork-ubsan.test
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@358726 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/fuzzer/CMakeLists.txt')
-rw-r--r--lib/fuzzer/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/fuzzer/CMakeLists.txt b/lib/fuzzer/CMakeLists.txt
index aa62995e7..f473910b2 100644
--- a/lib/fuzzer/CMakeLists.txt
+++ b/lib/fuzzer/CMakeLists.txt
@@ -66,6 +66,7 @@ elseif(TARGET cxx-headers OR HAVE_LIBCXX)
endif()
append_list_if(COMPILER_RT_HAS_OMIT_FRAME_POINTER_FLAG -fno-omit-frame-pointer LIBFUZZER_CFLAGS)
+append_list_if(True -fexceptions LIBFUZZER_CFLAGS)
if (CMAKE_CXX_FLAGS MATCHES "fsanitize-coverage")
list(APPEND LIBFUZZER_CFLAGS -fno-sanitize-coverage=trace-pc-guard,edge,trace-cmp,indirect-calls,8bit-counters)