summaryrefslogtreecommitdiff
path: root/lib/fuzzer/CMakeLists.txt
diff options
context:
space:
mode:
authorMatt Morehouse <mascasa@google.com>2018-06-12 19:43:40 +0000
committerMatt Morehouse <mascasa@google.com>2018-06-12 19:43:40 +0000
commit42feb163602372757c9a7b7255d0f09687201f89 (patch)
treed8d5f8e5902b7617381c8a5b043f870a6655ff5e /lib/fuzzer/CMakeLists.txt
parentdbc1c7ec281472bd76368cf1918c8c4bd718f62f (diff)
downloadcompiler-rt-42feb163602372757c9a7b7255d0f09687201f89.tar.gz
Revert r334458, r334220, r334212, r334139.
Reverts changes to AddCompilerRT.cmake due to breakage of http://lab.llvm.org:8011/builders/sanitizer-x86_64-linux/. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@334528 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/fuzzer/CMakeLists.txt')
-rw-r--r--lib/fuzzer/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/lib/fuzzer/CMakeLists.txt b/lib/fuzzer/CMakeLists.txt
index 085a981b3..e934d1b16 100644
--- a/lib/fuzzer/CMakeLists.txt
+++ b/lib/fuzzer/CMakeLists.txt
@@ -105,7 +105,6 @@ if(OS_NAME MATCHES "Linux|Fuchsia" AND COMPILER_RT_LIBCXX_PATH)
-fvisibility=hidden
CMAKE_ARGS -DCMAKE_CXX_COMPILER_WORKS=ON
-DLIBCXX_ENABLE_EXCEPTIONS=OFF
- -DLIBCXX_ENABLE_SHARED=OFF
-DLIBCXX_CXX_ABI=none)
target_compile_options(RTfuzzer.${arch} PRIVATE -isystem ${LIBCXX_${arch}_PREFIX}/include/c++/v1)
add_dependencies(RTfuzzer.${arch} libcxx_fuzzer_${arch}-build)