summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2013-03-27 09:49:35 +0000
committerRichard Hughes <richard@hughsie.com>2013-05-13 09:38:29 +0100
commit3e133d378cc21803914b1bb82dbf2d1882c77768 (patch)
tree71557bdca65203f77005dc322cb6230a7d3e56cb /configure.ac
parentea2cef35fb8126f221f39dc9c221aa4c1564625a (diff)
downloadcolord-3e133d378cc21803914b1bb82dbf2d1882c77768.tar.gz
libcolord: Show all the translations when dumping an ICC profile
Note: You need a new version of lcms2 for this to work.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 47f8e10..1135220 100644
--- a/configure.ac
+++ b/configure.ac
@@ -157,6 +157,10 @@ AC_CHECK_LIB(lcms2, cmsGetToneCurveEstimatedTableEntries, have_lcms_table_entrie
if test x$have_lcms_table_entries != x; then
AC_DEFINE(HAVE_LCMS_GET_TABLE_ENTRIES,1,[cmsGetToneCurveEstimatedTableEntries is available])
fi
+AC_CHECK_LIB(lcms2, cmsMLUtranslationsCount, have_lcms_mlu_translations_count=yes)
+if test x$have_lcms_mlu_translations_count != x; then
+ AC_DEFINE(HAVE_LCMS_MLU_TRANSLATIONS_COUNT,1,[cmsMLUtranslationsCount is available])
+fi
PKG_CHECK_MODULES(SQLITE, sqlite3)