summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2012-05-03 10:27:41 +0100
committerRichard Hughes <richard@hughsie.com>2012-05-03 16:12:31 +0100
commit257d03d5e39f63ba7a2409ed1a3a3deecd6d5d91 (patch)
treee06fbe9b77ab7994cea79ea79d01e49111dfaad1 /Makefile.am
parentdc65fc9e88e775bf4a838ed6bca8e11e40581d11 (diff)
downloadcolord-257d03d5e39f63ba7a2409ed1a3a3deecd6d5d91.tar.gz
Add CdWindow which allows us to get the color profile for a GtkWidget
This commit adds a gtk-3.0 dep to the new libcolord-gtk. You can split this out into a seporate subpackage if this makes things easier to install on headless things like print servers.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6818189..2e39cb8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,12 +18,19 @@ SUBDIRS = \
src \
po
+if HAVE_GTK
+SUBDIRS += \
+ libcolord-gtk
+endif
+
snapshot:
$(MAKE) dist distdir=$(PACKAGE)-$(VERSION)-`date +"%Y%m%d"`
DISTCHECK_CONFIGURE_FLAGS = \
--enable-introspection \
--enable-fd-fallback \
+ --enable-gtk \
+ --enable-gtk-doc \
--with-systemdsystemunitdir=$$dc_install_base/$(systemdsystemunitdir)
EXTRA_DIST = \