summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 7 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index e947c84..118257e 100644
--- a/meson.build
+++ b/meson.build
@@ -94,7 +94,6 @@ endforeach
glib = dependency('glib-2.0', version : '>= 2.28.0')
gio = dependency('gio-2.0', version : '>= 2.25.9Z')
-gtk3 = dependency('gtk+-3.0')
colord = dependency('colord', version : '>= 0.1.27')
if get_option('gtk2')
@@ -102,6 +101,10 @@ if get_option('gtk2')
conf.set('HAVE_GTK2', '1')
endif
+if get_option('gtk3')
+ gtk3 = dependency('gtk+-3.0')
+endif
+
if get_option('gtk4')
gtk4 = dependency('gtk4', version : '>= 4.4')
endif
@@ -144,7 +147,9 @@ root_incdir = include_directories('.')
subdir('libcolord-gtk')
subdir('po')
-subdir('client')
+if get_option('gtk3')
+ subdir('client')
+endif
if get_option('docs')
subdir('doc')
endif