summaryrefslogtreecommitdiff
path: root/Tests/Policy0002/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-09-28 17:34:34 -0400
committerBrad King <brad.king@kitware.com>2009-09-28 17:34:34 -0400
commit65a78ec5b81529507bed1375a13fca23bed60be7 (patch)
tree92499f72eb6092239b8bcf60438f7085a5bffe72 /Tests/Policy0002/CMakeLists.txt
parent0089f9cf8f0ff484b83b03d1fc11fbd2536d59b9 (diff)
downloadcmake-65a78ec5b81529507bed1375a13fca23bed60be7.tar.gz
Test support for OLD behavior of policy CMP0002
Policy CMP0002's OLD behavior allows duplicate non-custom targets. We test it with a project that builds two executables of the same name by setting CMP0002 to OLD.
Diffstat (limited to 'Tests/Policy0002/CMakeLists.txt')
-rw-r--r--Tests/Policy0002/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/Tests/Policy0002/CMakeLists.txt b/Tests/Policy0002/CMakeLists.txt
new file mode 100644
index 0000000000..0f6d3319a7
--- /dev/null
+++ b/Tests/Policy0002/CMakeLists.txt
@@ -0,0 +1,5 @@
+cmake_minimum_required(VERSION 2.6)
+project(Policy0002 C)
+cmake_policy(SET CMP0002 OLD)
+add_subdirectory(A)
+add_executable(Policy0002 policy0002.c)