summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ab35749fce..69679538f7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -335,13 +335,17 @@ option(CLANG_INCLUDE_TESTS
"Generate build targets for the Clang unit tests."
${LLVM_INCLUDE_TESTS})
-# TODO: docs.
-
if( CLANG_INCLUDE_TESTS )
add_subdirectory(test)
add_subdirectory(unittests)
endif()
+option(CLANG_INCLUDE_DOCS "Generate build targets for the Clang docs."
+ ${LLVM_INCLUDE_DOCS})
+if( CLANG_INCLUDE_DOCS )
+ add_subdirectory(docs)
+endif()
+
# Workaround for MSVS10 to avoid the Dialog Hell
# FIXME: This could be removed with future version of CMake.
if( CLANG_BUILT_STANDALONE AND MSVC_VERSION EQUAL 1600 )