summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Gottesman <mgottesman@apple.com>2013-08-28 20:29:40 +0000
committerMichael Gottesman <mgottesman@apple.com>2013-08-28 20:29:40 +0000
commit1ab6c6c80b53f88ff245f17b243609853d76446b (patch)
tree6e240533338b354514e66abd35d831074ece849c /CMakeLists.txt
parent4a68491fa179572e6b2c1364e7ff24c05110324b (diff)
downloadclang-1ab6c6c80b53f88ff245f17b243609853d76446b.tar.gz
[doxygen] Added code for generating doxygen documentation for clang for cmake.
git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@189508 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ab35749fce..69679538f7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -335,13 +335,17 @@ option(CLANG_INCLUDE_TESTS
"Generate build targets for the Clang unit tests."
${LLVM_INCLUDE_TESTS})
-# TODO: docs.
-
if( CLANG_INCLUDE_TESTS )
add_subdirectory(test)
add_subdirectory(unittests)
endif()
+option(CLANG_INCLUDE_DOCS "Generate build targets for the Clang docs."
+ ${LLVM_INCLUDE_DOCS})
+if( CLANG_INCLUDE_DOCS )
+ add_subdirectory(docs)
+endif()
+
# Workaround for MSVS10 to avoid the Dialog Hell
# FIXME: This could be removed with future version of CMake.
if( CLANG_BUILT_STANDALONE AND MSVC_VERSION EQUAL 1600 )