summaryrefslogtreecommitdiff
path: root/unittests/ASTMatchers/CMakeLists.txt
diff options
context:
space:
mode:
authorAaron Ballman <aaron@aaronballman.com>2016-03-08 16:34:37 +0000
committerAaron Ballman <aaron@aaronballman.com>2016-03-08 16:34:37 +0000
commite2c9bf152849e244effa38d0654d3246e0399810 (patch)
treed13e2fb492f4211d9c6fa5e22cedcc259a4c86bd /unittests/ASTMatchers/CMakeLists.txt
parent2ac86c73e7fcb52593064d8ab84f1d5552a0e3e6 (diff)
downloadclang-e2c9bf152849e244effa38d0654d3246e0399810.tar.gz
Turning on the /bigobj flag for two more files that will not link with MSVC 2015 Win64 Debug due to the section limit.
git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@262938 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'unittests/ASTMatchers/CMakeLists.txt')
-rw-r--r--unittests/ASTMatchers/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/unittests/ASTMatchers/CMakeLists.txt b/unittests/ASTMatchers/CMakeLists.txt
index 3ace9fe264..81d36ea99a 100644
--- a/unittests/ASTMatchers/CMakeLists.txt
+++ b/unittests/ASTMatchers/CMakeLists.txt
@@ -2,6 +2,12 @@ set(LLVM_LINK_COMPONENTS
Support
)
+# By default MSVC has a 2^16 limit on the number of sections in an object file,
+# and this needs more than that.
+if (MSVC)
+ set_source_files_properties(ASTMatchersTest.cpp PROPERTIES COMPILE_FLAGS /bigobj)
+endif()
+
add_clang_unittest(ASTMatchersTests
ASTMatchersTest.cpp)